小林博客为安全WordPress升级至5.2版本,明确PHP最低版本

随着WordPress程序使用量日趋上升,官方开发团队也越来越重视程序的各种安全细节。

  • 《喜大奔普,全球前1000万个网站中1/3是WordPress搭建的》

之前5.1版本上线的 Health Check(后台-工具中) ,就是专门针对网站自身的健康检测,提出网站的现有问题或给出更好的解决方法。

  • 《旧WordPress出现跨站点脚本漏洞,建议尽快升级至5.1.1版本》

WordPress 5.2版本,命名为“Jaco”,以纪念着名和革命性的爵士贝司手Jaco Pastorius,可在WordPress仪表板中下载或更新。如果出现问题,此更新中的新功能可以比以往更轻松地修复您的网站。还有更强大的工具可用于识别和修复配置问题和致命错误。无论您是帮助客户的开发人员还是您自己管理网站,这些工具都可以帮助您在需要时获得正确的信息。

20190516214238-3

WordPress 5.2 版本的主要更新内容:

  • 强化 Health Check 功能,让站长更加明确的了解网站健康情况,它还增加了开发人员可以为站点维护人员提供调试信息的空间;
  • PHP错误保护,它具有更好的处理所谓的“死亡白屏”,这个功能主要是监测运行的插件或主题如有致命报错,将暂停插件或主题的运行,以确保网站的可访问;
  • PHP最低版本提高到5.6.20,也就是说,如果你想要在今后继续使用 WordPress 的最新版本,你的服务器必须保证PHP版本不低于 5.6.20;
  • 新增了一个 wp_body_open 钩子,它允许主题在<body>元素的开头注入代码,对普通用户没啥实际用途,开发者有用。
  • 辅助功能更新:许多变化协同工作,以改善使用屏幕阅读器和其他辅助技术的人的上下文感知和键盘导航流程。
  • 新的仪表板图标:十三个新图标,包括Instagram,BuddyPress的一套图标,以及全球包含的旋转地球图标。在仪表板中找到它们并享受一些乐趣!
  • 插件兼容性检查:WordPress现在将自动确定您的网站的PHP版本是否与已安装的插件兼容。如果插件需要比您的网站当前使用的更高版本的PHP,WordPress将不允许您激活它,以防止潜在的兼容性错误。
  • 构建JavaScript:通过在 wordpress/scripts  包中添加webpack和Babel配置,开发人员不必担心设置复杂的构建工具来编写现代JavaScript。
 收藏 (0) 打赏

您可以选择一种方式赞助本站

支付宝扫一扫赞助

微信钱包扫描赞助

未经允许不得转载:小林博客 www.vvso.cn小林博客 » 小林博客为安全WordPress升级至5.2版本,明确PHP最低版本

分享到: 更多 (0)

评论 抢沙发

切换注册

登录

忘记密码 ?

切换登录

注册